Mobile Ewallet Application

Looking to use Allied Wallet's services on your phone?

Blackberry users can now enjoy accessing their Allied Wallet E-Wallet from their Blackberry!
Note: You must have a BlackBerry OS 5.0 or higher installed on your mobile device to make our application work correctly.

 

 

Internet Explorer Users only, download the Mobile Ewallet Application on your device now!!

 

 

 

Blackberry browser Users, download the Mobile Ewallet Application directly onto your Blacberry device now over the air!!

ewallet login